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User Manual for

TeraRanger Evo with:
USB and I2C/UART
backboard

(Hardware revision 1.0, Firmware revision 1.0.0)

Technical support: support@teraranger.com
Sales and commercial support: teraranger@terabee.com
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Introduction

The purpose of this document is to give guidelines for use and integration of the TeraRanger
Evo distance sensor with (a) UART/I2C backboard, and/or (b) USB backboard using these
standard communication interfaces.

Mechanical integration

The mechanical design of the main sensor module (black) allows easy assembly to its
backboard (yellow) using a simple ‘clip-in’ technique. (When you clip the two together,
ensure there is no visible gap between the black and yellow parts.) The yellow backboard
has two mounting holes for final installation.

When choosing a place for mounting, please consider the following recommendations:

Choose a place which is in accordance with the optical constraints listed in below
Mounting close to sources of heat or strong electromagnetic fields can decrease the
sensing performance

e Do not mount anything directly in front of the sensor or in a cone of approximately
+/-15° around the central optical axis of the sensor

e Within the first metre of the sensor, avoid objects with high surface reflectivity in a
cone of approximately +/-45° around the central optical axis of the sensor

e |t is better to avoid having other sources of Continuous Wave or modulated IR light
close to the sensor
Please consider that dust, dirt and condensation can affect the sensor performance
It is not advised to add an additional cover in front of the sensor
Drone rotor blades, or other environments with flickering (‘chopped’) ambient light in
the field of view can affect sensors’ readings
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Sensor handling during system assembly

During assembly and integration, please observe all common ESD precautions. All optical
surfaces (sensor front) should be kept clean and free from contact with chemicals.

USB backboard use

|

The USB backboard comes with a standard Micro-USB connector.

Connecting the TeraRanger Evo to a Host Computer

TeraRanger Evo can interact as a virtual COM port using the following configuration: 115200
bit/s, 8 data bits, no parity bit and one stop bit.

Graphical User Interface

A free graphical user interface is available for Windows, providing an easy way to visualise
the data from your TeraRanger Evo. This is useful for demonstration, testing purposes and
checking some of the basic parameters of the sensor. It also provides a way to easily
upgrade the firmware running on the device.

Prerequisites

For usage on Windows (7, 8, 10) operating system, please download the driver from
http://www.st.com/en/development-tools/stsw-stm32102.html and follow the ”ReadMe file”

instructions given by the installer. After successful installation, unplug the interface for a
few seconds, and plug it back in. The virtual COM port should now be available on your PC.

Basic Operation

Make sure your TeraRanger Evo is connected to a USB port on your computer. Select File >
Connect. You should immediately see a distance reading in millimetres and the status
should change to ‘Connected’.

Copyright © Terabee 2017
Terabee, 90 Rue Henri Fabre, 01630, St Genis-Pouilly, France

4/13

¥


http://www.st.com/en/development-tools/stsw-stm32102.html

TERA

o2’ TeraRanger Evo — >

File Help
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Status: Connected

Port: COomM3

Serial port opened

Firmware Upgrade

The current firmware version on your TeraRanger Evo can be found by selecting Help >
About in the graphical user interface. It is possible to upgrade the firmware running on your
device if a new firmware version is made available on the TeraRanger website.

Please note the Upgrade Firmware feature is only supported on Windows 7, 8 and 10.
Please carefully follow the steps outlined below to avoid ‘bricking’ your device.

Select File > Upgrade Firmware

You will be presented with a dialog window asking you to confirm your choice
Beyond this point, if you press ‘Yes'’ it will not be possible to revert to the firmware
currently running on your TeraRanger Evo. Press ‘No’ to cancel and keep the current
firmware or ‘Yes’ to continue

e Read the instructions in the dialog window that opens
e Press ‘Select FW’ and select the new firmware file with Windows File Explorer
e Press ‘Upgrade’ and wait until the operation finishes
e Close the Upgrade dialog box
Copyright © Terabee 2017
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In Windows you can also use any terminal emulation software of your choosing, however we
suggest you use HTerm (http://www.der-hammer.info/terminal/). Extract the downloaded zip
file to the folder of your choice, open it and double click on the “HTerm.exe” document.

Connect the TeraRanger Evo to your computer and select the corresponding USB port (click
“R” button to refresh the port list). Select values for the following fields: (1) Baudrate, (2)
Data Bits, (3) Parity, (4) Stop Bits. For easier readings, select the “LF” option for “Newline at”
tab. See Figure below for visual instructions.

i HTerm 0.8.1beta
File Options View Help

[ connect | port| \@ [aa..d 115200 v| Datals v| stop|1 v | Party |None v] [ €75 Flow control

Show newline
characters

w3

PR 0 [Reset | | 7x] 0] [eset | |? count[ o%]] 0| | Reset | | [Newine at | CR+LF V)

Once you have selected the USB port and required values, click on the “Connect” button.
The data will now appear in the “Received data” box (Figure below).

Selection (-)
Input control
Input options
Clear transmitted [ Asci [oec [lBin | Send onenter Mone v Send file OTR RTS

Ewerﬂ vi 00 11 01 45

To communicate with the terminal emulation software, you need to send a command in
hexadecimal via the “Type” box. First check the “Hex” checkbox and choose the “HEX”
Type. The figure above shows an example of the command which allows data to be shown
in TEXT mode.
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I2C/UART backboard use

[I2C/UART interface

[ o

L

The TeraRanger Evo can be controlled through 12C or UART interfaces. It uses a single 9
pin Hirose DF13 connector for interfacing to the host system. The mating connector is a
Hirose DF13-95-1.25C with crimping contacts DF13-2630SCF (tin) or DF13-2630SCFA
(gold). Please consider the mechanical stability of the mated connectors and avoid any kind
of excess force on the connector (during installation and once integrated) and follow the
recommendations in the Hirose DF13 series datasheet (available here:
https://www.hirose.com/product/en/products/DF13) to ensure a reliable connection.

Table 1 provides an overview of the pin out of the DF13 connector:

Pin out and description (According to DF13 datasheet)

Pin Designator | Description

1 Tx UART transmit output. 3.3V logic

2 Rx UART receive input. 3.3V logic

3 GND Power supply and interface ground

4 SDA I2C serial data line. 3.3V logic

5 SCL I2C serial clock line. 3.3V logic

6 rfu RESERVED FOR FUTURE USE

7 5V +5V supply input

8 GND Power supply and interface ground

9 rfu RESERVED FOR FUTURE USE
Copyright © Terabee 2017
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Backboard LEDs’

TERA

Five LEDs are mounted to give visual feedback on the sensor. Table 2 lists the functionality

of each LED:
LED Description
PWR (orange) Power indicator, on when 5V connected

Rx/Tx (red/green) UART receive and transmit indicators

LEDO/LED 1 For internal use only

Electrical characteristics

DC electrical characteristics

Parameter Minimum Typical Maximum
Power supply
Voltage input (V) 4.8 5 5.2
Current consumption (mA) 25 *200 350
Interface logic levels
(referenced to +3V3)
LOW - - 1
HIGH 2.3 - -

* Depending on ambient conditions, distance and target reflectivity
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|2C protocol information

The communication parameters are:
Frequency: 400kHz
Primary Address Length: 7-bit
Primary Slave Address: 0x31
Built-in pull-up resistors: 10kOhms on SDA and SCL

The TeraRanger Evo is ‘free running’. This means that it will restart a new measurement as
soon as the last one is finished. The displayed data via I12C protocol is always updated at the
end of a measurement. Nevertheless, it can always be read at any time.

Reading the distance is done by first writing a Trigger Reading command to the sensor -
send 0x62 (this is the 7 bit address 0x31 followed by the write bit ‘0’) and then reading from
the sensor by sending 0x63 (the base address with the Read bit ‘1’) followed by three byte
read operations. The first two bytes you receive are a 16 bit word containing the latest
measurement in mm**, the third byte is the CRC8 checksum.

**The TeraRanger Evo will output 01CRC (first distance byte set to zero and the second to
one) as an error message if the sensor is unable to measure a distance. If the target is
too close (below the minimum distance), the TeraRanger Evo will output 0OCRC (both
distance bytes set to zero). If the target is too far away (above the maximum distance), the
TeraRanger Evo will output XXCRC with XX = FFFFhex (both distance bytes set to OxFF)

Writing commands to the TeraRanger Evo:

1. Send the address byte consisting of a 7 bit base address and the last bit indicating
write (‘0’), e.g. 0x62 for base address 0x31. All commands listed in the table below
are ‘write operations’. The answer will be in the next read operation for which you
have to send the 7 bit address with the read bit set

2. Send the desired command listed in the table below (see table below in the next
paragraph)

3. In case the command creates an answer, read it back immediately

Reading data from the TeraRanger Evo:
1. Send the address byte consisting of 7 bit base address and the last bit indicating
read (‘1’), e.g. 0x63 for base address 0x31

2. Read back the the number of bytes imposed by the command, e.g. three bytes for a
distance reading
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I2C commands

Command Name Description

0x00 TRIGGER READING Write this command to the TeraRanger
Evo and after a wait of approximately
500us read the 3 byte distance response

0x01 WHO_AM | Write this value to TeraRanger Evo via
I2C and the device responds with 0xA1

0xA2 CHANGE_BASE_ADDR!" | Write this value followed by the new
address to set 1, eg. send 0x42 if you
want the Evo’s base address to change
to 0x42, ignore Read/Write bits.

Wait at least 1 second for the
TeraRanger Evo to rejoin the 12C bus
with the new address.

1] This command assigns a base address that will be memorised by the TerRanger Evo ie. power cycling the Evo will not
restore the default I2C address.

[2] Valid addresses accepted by the TeraRanger Evo are in the range 0x02 to 0x7F. Assignment of addresses within a local
system is up to the system architect. For example, the 12C standard defines reserved addresses but if it is known that the
reserved address is never going to be used for its intended purpose, a reserved address can be used as the Evo 12C Base
Address.

UART Communication

UART protocol information

The UART communication for the TeraRanger Evo uses a simple Modbus-like protocol. The

communication parameters are:

Baud Rate: 115 200
Data Bits: 8

Stop Bit(s): 1

Parity: None

HW Flow Control: None
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Commands
Address | Command Data CRC-8
0x00 PRINTOUT MODE TEXT 0x45
0x11 0x01
0x00 PRINTOUT MODE BINARY 0x4C
0x11 0x02

The default mode of TeraRanger Evo is Binary mode. For changing the output format to Text
mode, please use the following command in hexadecimal: 00 11 01 45. Accordingly, to
switch back to Binary mode use the hexadecimal command: 00 11 02 4C.

UART output format

Two output formats are available:

Text Data output in human readable form (5 to 7 bytes message):
output

XXXxXx\n

- Distance reading in millimeters* (maximum 5 bytes per sensor):
XXXXX

- New line character: \n (10 decimal / 0xOA hex)

*please be aware that there is no zero-padding for leading zeros!
- If the TeraRanger Evo is unable to measure a distance, it will output
-1\n as an error message
- If the target is too close (below the minimum distance), the
TeraRanger Evo will output -Inf\n
- If the target is too far away (above the maximum distance), the
TeraRanger Evo will output +Infin

Binary Data output (4 bytes message):
output

TXXCRCS8

- Header (1 byte): T (84 decimal / 0x54 hex)
- Distance reading in millimeters** (2 bytes): XX
- Checksum (1 byte) of previous 3 bytes: CRC8
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**The TeraRanger Evo will output TO1CRC (first distance byte set to zero
and the second to one) as an error message if the sensor is unable to
measure a distance:

- If the target is too close (below the minimum distance), the
TeraRanger Evo will output TOOCRC (both distance bytes set to
zero)

- If the target is too far away (above the maximum distance), the
TeraRanger Evo will output TXXCRC with XX = FFFFhex (both
distance bytes set to OxFF)
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Declaration of Conformity
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Declaration of Conformity
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c € CE certified, eye-safe and RoHS compliant
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